·
Service working normally now.
Resolved
Monitoring
The issue has been resolved, we are monitoring system health
Investigating
Some customers are experiencing issues loading Wordsmith website. We are investigating the issue